Export Issue
Incident Report for FluidSurveys
Resolved
Exports are now back in working order.
Posted over 2 years ago. Jun 08, 2015 - 12:44 EDT
Investigating
We are currently looking into an issue causing some exports to not function correctly.
Posted over 2 years ago. Jun 08, 2015 - 12:37 EDT